OSSEC HIDS Aktualisierungsproblem bei ossec-hids-agent_2.8.2-1wheezy_amd64.deb

Leider scheint bei den OSSEC HIDS Paketen (für Debian/Ubuntu zumindest) irgendwo ein kleiner Fehler bei Updates vorprogrammiert zu sein - bei Updates auf mehreren Servern bekam ich von APT immer nur Fehlermeldungen, hier ein kompletter Auszug:

Vorbereitung zum Ersetzen von ossec-hids-agent 2.8.1-1wheezy (durch .../ossec-hids-agent_2.8.2-1wheezy_amd64.deb) ...
Ersatz für ossec-hids-agent wird entpackt ...
Entferne Benutzer »ossec« ...
Warnung: Die Gruppe »ossec« hat keine Mitglieder mehr.
userdel: Gruppe ossec ist die primäre Gruppe eines anderen Benutzers und wird
nicht entfernt.
Fertig.
/usr/sbin/delgroup: »ossecm« hat immer noch »ossec« als primäre Gruppe!
dpkg: Warnung: Unterprozess altes post-removal-Skript gab den Fehlerwert 7 zurück
dpkg: stattdessen wird Skript aus dem neuen Paket probiert ...
/usr/sbin/deluser: Der Benutzer »ossec« existiert nicht.
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/ossec-hids-agent_2.8.2-1wheezy_amd64.deb (--unpack):
 Unterprozess neues post-removal-Skript gab den Fehlerwert 2 zurück
/usr/sbin/deluser: Der Benutzer »ossec« existiert nicht.
dpkg: Fehler beim Aufräumen:
 Unterprozess neues post-removal-Skript gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/ossec-hids-agent_2.8.2-1wheezy_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Was nun? Meine Lösung ist vermutlich nicht perfekt, funktioniert aber allemal - ich habe die von OSSEC angelegten User entfernt, einen neuen hinzugefügt (der beim Update dann wieder entfernt wird):

# userdel ossecm
# userdel ossecr
# useradd ossec -g ossec

Danach das Update erneut durchführen und es sollte funktionieren.

Kategorie: 
Thanks for voting! You help me make my website better.

Neuen Kommentar schreiben